Laravel Homestead hangs by SSH Auth method

I have a problem with Laravel Homestead on Windows 7. When I start vagrant, it hangs on:

SSH auth method: private key

I don’t know why this is so. I've tried a number of solutions. Here's the auth stuff from my homestead.yaml file:

authorize: C:/Users/Kim.Ward/.ssh/

    - C:/Users/Kim.Ward/.ssh/id_rsa


I've also tried:

authorize: ~/.ssh/

    - ~/.ssh/id_rsa


I tried to add:

   config.ssh.private_key_path = "C:/Users/Kim.Ward/.ssh/id_rsa"



config.ssh.username = "vagrant"
config.ssh.password = "vagrant"


I can confirm that virtualization is enabled and I am using an i5 6500.

If I check the virtual box while the window is loading, I see a login prompt in the preview window. I can also double click the instance in the virtual box and it will open and allow me to login, but it doesn't seem like the setup process is complete.

I am using Virtual Box version 5.1.18 and Vagrant v1.9.1. I've tried with other minor versions.

Any help would be greatly appreciated. I'm running out of ideas for this moment.




source to share

All Articles