"dojo not defined" issue with Firefox 3.5?

Please take a look at this code: http://3wcloud-com-provisioning-qa.appspot.com/testAjaxDojo Just open the "domain" input box to try the Ajax. (Note: the test Ajax web service always sends back the same message, it pretends to check if the domain is available, but it really isn't).

When running in Firefox 3.5, I get "dojo not defined" in the dojo.xhrGet statement. It works great in IE7 and Chrome browsers and one was tested in Firefox 3.0 and it worked.

1) Is there something wrong with Firefox 3.5 without getting the javascript dojo from the CDN? Perhaps a caching issue?

2) Do you know what the dojo guru is about this problem? Is this something that has already been reported in Firefox?

Thanks, Neil Walters

Update: 9/1 / in the afternoon - I uninstalled and reinstalled Firefox 3.5.2 (but I kept my profile settings) and got the same problem. I am on Windows Vista Ultimate.


source to share

3 answers

Finally found the problem. It was an add-on called "No-Script". Even though I installed No-Script to allow scripts globally, something in this tool was causing the problem. I updated to a newer version of No-Script and was still having problems. If I disable the add-on (on the Tools / Add-ons screen), Dojo boots fine from the CDN and life is good again.

I probably lost 6-8 hours on this stupid issue. Hope this post will save someone else. Please vote up the answer if this happens.



As I said in my comment, Firefox 3.5 (mac) works great. Try the following in your Firefox browser, paste the dojo library url in the url bar:



This usually fixes any cache issues and forces Firefox to fetch the file.

If it still doesn't work, just save the dojo on your server and use it locally.



It works great here when NoScript is enabled. I just needed to allow "3wcloud-com-provisioning-qa.appspot.com" and "ajax.googleapis.com".



All Articles