Apache low memory error

mod_python (?) ate a lot of ram (about 9mb per worker). If I open multiple TRAC pages at once, many of them will have an error due to missing ram (64MB virtual limit). if i limit worker threads to 3 i can get everything ok. The problem is, if nobody is accessing TRAC, I have a lot of ROMs that are not being used.

Is there a way that I can either

  • Limit the amount of workflow that python can use?
  • Limit the number of workflows in my trac path?
  • Apache spawns as many worker processes or threads as they want, but they only appear if X or RAM is free (or when X or lower is used by Apache).
  • Something else?

source to share

1 answer

You can configure the second mod_python

apache with minimal worker threads to run on local interface only and with a different port, i.e. . Then, for your public apache instance on port 80, disable mod_python and configure it for optimal use. Proxy all trac apps and other python apps for local instance mod_python


If the apache-facing post remains for static content only, then consider replacing it with something lightweight like nginx or lighttpd .



All Articles