What is the best name for an object for collecting semantically related inputs?

I am writing an HTML form generation library. There's a top-level Form class, and at the bottom there are classes for each type of HTML form input object (Select, Textfield, Radio, etc.). There is a class in between that contains groups of 1 or more semantically related input objects.

For example, one type of this class could be named "Login" and contain a text field input and a password input. As another example, the main use of the form library would be to create online surveys, so the intermediate classes would be different survey types.

My question is what in general to name these middleware classes. Some of the things that have been proposed in our working group are "Set", "Fieldset", "Group", "Block", "Chunk" and "Conglomeration".

Some of these suggestions are "good", but none of them worked "it!" interrupt. (The one that comes closest is the last one, but that is (a) too long and (b) too prone to misbehaving.) Does anyone have a better suggestion?

+1


source to share


5 answers


After further discussion in our working group, we are done with the "fieldset".



Thanks for all the suggestions.

0


source


Component as in "Entry Element" or "Multiple Answer Component".



FYI. I find http://thesaurus.reference.com very helpful for problems like this.

+1


source


just name it Foo or SematicallyRelatedInputs1 and start coding. a sensible name should happen to you pretty soon. don't feel bad if you change your name multiple times.

+1


source


'FormBlob' possible?

'GroupedInput?

If single-word terms fail, lean back on multi-managed mashups =)

+1


source


TagSet can work. If I understand you correctly, you have used combinations of two things like:

<input type="text" /> <input type="password"/>

      

and

informal elements:

<dl>
  <dt>Question</dt>
  <dd>Answer<dd>
</dl>

      

or

All collections of HTML tags. TagSet looks like a simple descriptive name.

+1


source







All Articles