JQuery.holdReady (false) - errors on call

I am using yepnope.js to conditionally load css and js files into my page.

I have combined my JS files into one file. The structure looks like this:

/* file */

// - copy pasted Jquery 1.7rc2.min here -

(function () { console.log("enabled hold"); jQuery.holdReady(true); })();

// - copy pasted yepnope.min here -

    test: condition,
    load: [css files]
     load:[js files],
     callback: function () {...},
     complete: function () { jQuery.holdReady(false); console.log("hold released");}

/* end of file */


and this is the error i get on the chrome console chrome (version 17.xx)

Uncaught TypeError: Object function ( selector, context ) {
        // The jQuery object is actually just the init constructor 'enhanced'
        return new jQuery.fn.init( selector, context );
    } has no method 'holdReady'
(anonymous function)animatein.js:2
(anonymous function)


I read the list of yepnope errors and tried alternative mentodes like having "holdrelease.js" and only jQuery.holdRelease (false); in it and put it as the last item in the queue. I ended up with the same error.

Can someone please explain what is wrong here, I am missing something important? I'm confused...


source to share

All Articles